Eastern Online – Technical Requirements

EasternOnline – Technical Requirements

Technical Requirements (PDF)

Technical Requirements for using Blackboard Vista 4.x.
The following are the minimal system requirements, which your Personal Computer must comply with in order to use Blackboard Vista 4.x successfully.

WebCT Browser Tuneup

Browser Tune-Up for Campus Edition and Vista.
Before using Blackboard Learning System Campus Edition or Vista (formerly “WebCT,”) make sure that you are using a supported browser and that your browser settings are correct.

Browser Tune-Up Information

You can access the following information from the provided link.

  • List of supported browsers
  • Determine your browser version
  • Determine your Blackboard version
  • Using Browser Plug-Ins